Diagnostisch hulpprogramma voor DirectX

De documentatie van het diagnostisch hulpprogramma voor DirectX van Microsoft bevat de volgende onderwerpen:

  • Diagnostisch hulpprogramma voor DirectX - overzicht
  • Het diagnostisch hulpprogramma voor DirectX gebruiken om problemen op te sporen
  • DirectX-onderdelen testen
  • Standaardgedrag wijzigen
  • Informatie opslaan
  • Controleren op digitale handtekeningen van WHQL


Diagnostisch hulpprogramma voor DirectX - overzicht

In het diagnostisch hulpprogramma voor DirectX van Microsoft wordt informatie verzameld over de DirectX API-onderdelen (Application Programming Interface) en -stuurprogramma's op uw systeem. Met dit hulpprogramma kunt u geluid, grafische uitvoer en Microsoft DirectPlay-serviceproviders testen. Ook kunt u met dit hulpprogramma bepaalde functies voor hardwareversnelling uitschakelen.

U kunt het diagnostisch hulpprogramma gebruiken om informatie te verzamelen voor een technicus als u belt voor ondersteuning. U kunt de verzamelde informatie opslaan en in een e-mailbericht plakken.

De gegevens worden op een reeks pagina's weergegeven. U kunt als volgt van de ene pagina naar de andere gaan:

  • Klik op de tabbladen.
  • Klik op Volgende pagina.
  • Druk op PIJL-LINKS of PIJL-RECHTS als een tabblad de focus heeft.

Op sommige pagina's in het diagnostisch hulpprogramma, zoals DirectX-bestanden, Muziek of Invoer, wordt informatie weergegeven in een tabel. U kunt de informatie in deze tabellen sorteren om de gewenste gegevens makkelijker te kunnen vinden.

Informatie in een tabel sorteren

  1. Zoek de kolom met informatie waarmee u de tabel wilt sorteren.
  2. Klik op de kop boven aan de kolom.

    De tabel wordt gesorteerd in alfabetische of numerieke volgorde, afhankelijk van de items in de kolom. Als u de sorteervolgorde wilt omkeren (bijvoorbeeld van Z naar A in plaats van van A naar Z), klikt u nogmaals op de kolomkop.

* Opmerkingen

  • Sommige waarden, zoals de hoeveelheid geheugen op een beeldschermkaart, zijn mogelijk globale waarden.
  • Als u meer wilt weten over het opslaan van informatie die is verzameld met het diagnostisch hulpprogramma voor DirectX, klikt u op Verwante onderwerpen.

Verwante onderwerpen

DirectX-onderdelen testen

Informatie opslaan


Het diagnostisch hulpprogramma voor DirectX gebruiken om problemen op te sporen

Als zich problemen voordoen bij het uitvoeren van Microsoft DirectX-toepassingen, kan het diagnostisch hulpprogramma voor DirectX u helpen de oorzaak van deze problemen te vinden. Hier volgen enkele mogelijke oorzaken van problemen die het diagnostisch hulpprogramma kan opsporen:

  • Onjuiste versies van DirectX-onderdelen. Zoek in de sectie Opmkeringen van de pagina DirectX-bestanden naar waarschuwingen over bèta- en foutopsporingsbestanden (debug-bestanden). Bètabestanden zijn vroege testversies van bestanden die niet samen met commerciële programma's moeten worden geïnstalleerd. Foutopsporingsversies, die worden gebruikt tijdens de ontwikkeling van het programma, moeten niet worden geïnstalleerd in combinatie met het uiteindelijke product. Als u de foutopsporingsversies van onderdelen gebruikt, kunnen programma's veel trager worden dan deze in de handelsversie zouden zijn.
  • Geen hardwareversnelling. Sommige programma's worden zeer langzaam of helemaal niet uitgevoerd, tenzij hardwareversnelling van Microsoft DirectDraw of Direct3D beschikbaar is. Kijk op de pagina Beeldscherm onder DirectX-functies om na te gaan of DirectDraw-versnelling, Direct3D-versnelling of AGP-oppervlakteversnelling is gemarkeerd als 'Niet beschikbaar'. Als dat het geval is, kunt u overwegen uw hardware bij te werken. Als u een product gebruikt uit de Windows .NET Server 2003-familie, moet u mogelijk versnelling voor afbeeldingen gebruiken. U doet dit door Beeldscherm te openen in het Configuratiescherm, het tabblad Instellingen te selecteren en op Geavanceerd te klikken. Selecteer het tabblad Probleem oplossen en zet de schuifregelaar Hardwareversnelling op Maximaal.
  • Het apparaat is niet aangesloten. Als een joystick of een ander invoerapparaat niet reageert, is het mogelijk niet goed ingesteld. Controleer of het apparaat voorkomt op de pagina Invoer van het diagnostisch hulpprogramma voor DirectX. Als dat niet het geval is, voegt u het apparaat toe via het Configuratiescherm.
  • Niet-ondertekende stuurprogramma's. Niet-ondertekende stuurprogramma's zijn niet getest door Microsoft om vast te stellen of deze volledige compatibel zijn met de nieuwste versie van DirectX. U wordt geadviseerd stuurprogramma's te gebruiken die digitaal zijn ondertekend door Windows Hardware Quality Labs (WHQL) van Microsoft.

* Opmerking

  • Als u Terminal Services gebruikt om te werken op een extern systeem dat hardwareversnelling ondersteunt, geeft het diagnostisch hulpprogramma voor DirectX mogelijk aan dat ondersteuning voor hardwareversnelling beschikbaar is. Terminal Services kan echter niet werken met hardwareversnelling, dus is ondersteuning voor hardwareversnelling niet beschikbaar.

Verwante onderwerpen

Informatie opslaan

Controleren op digitale handtekeningen van WHQL


DirectX-onderdelen testen

U kunt Microsoft DirectDraw en Direct3D testen op elke monitor die op uw systeem is aangesloten. Ook kunt u DirectSound testen op elk wave-uitvoerapparaat en kunt u DirectMusic testen op elke muziekpoort.

U test een DirectX-functie als volgt:

  1. Klik op de betreffende pagina op de knop Testen.
  2. Lees eventuele berichten die worden weergegeven.
  3. Kijk of luister naar de tests.
  4. Voer de test helemaal uit totdat er een bericht wordt weergegeven waarin u wordt gevraagd of de test geslaagd is. Als u Nee antwoordt, worden er geen andere tests meer uitgevoerd.

Als u DirectMusic test, wordt er slechts één test uitgevoerd. Klik op OK als u met zekerheid hebt kunnen vaststellen dat de muziek al dan niet op de gewenste manier wordt afgespeeld.

U kunt de Microsoft DirectPlay-functionaliteit bij elke beschikbare serviceprovider testen.

DirectPlay testen

  1. Klik op de pagina Netwerk op DirectPlay testen.
  2. Typ in het dialoogvenster DirectPlay testen een gebruikersnaam en kies een serviceprovider.
  3. Selecteer Nieuwe sessie maken en klik vervolgens op OK.
  4. Als u een modemverbinding hebt gekozen, klikt u in het dialoogvenster Modemverbinding op Antwoorden om de modem in te stellen op de modus voor automatisch beantwoorden.

Voer het diagnostisch hulpprogramma voor DirectX van Microsoft uit op een andere computer die de geselecteerde verbinding kan maken met de eerste computer.

  1. Klik op DirectPlay testen.
  2. Typ een andere gebruikersnaam.
  3. Kies dezelfde serviceprovider.
  4. Klik op Deelnemen aan bestaande sessie en klik vervolgens op OK.

    Voor bepaalde typen verbindingen moet u mogelijk meer gegevens opgeven, zoals een telefoonnummer. Als u een TCP/IP-verbinding wilt maken via een lokaal netwerk, kunt u het tekstvak leeg laten.

  5. Selecteer de naam van de sessie in de Sessielijst met de naam van de sessie die u op de eerste computer hebt gemaakt.
  6. Op beide computers moet nu een chatvenster worden weergegeven. Typ een bericht in het invoervak op de ene computer en klik vervolgens op Verzenden. Als het goed is, wordt het bericht nu in het schuifgebied van het chatvenster op beide computers weergegeven.


Standaardgedrag wijzigen

Op de pagina Geluid kunt u een ander niveau instellen voor de hardwareversnelling door de schuifregelaar te verschuiven. U moet een systeembeheerder zijn om het niveau van de hardwareversnelling te kunnen wijzigen. Dit niveau blijft van kracht nadat u het diagnostisch hulpprogramma voor DirectX van Microsoft hebt gesloten.

U kunt de hardwareversnelling voor Microsoft DirectDraw of Direct3D uitschakelen, als deze versnelling beschikbaar is. Als u de hardwareversnelling wilt uitschakelen, gaat u voor elk weergaveapparaat naar de pagina Beeldscherm en klikt u op Uitschakelen. Als u de hardwareversnelling eenmaal hebt uitgeschakeld, is deze versnelling, zelfs nadat u het diagnostisch hulpprogramma voor DirectX hebt gesloten, voor geen enkele toepassing meer beschikbaar. Als u de hardwareversnelling opnieuw wilt inschakelen, klikt u op Inschakelen op de betreffende beeldschermpagina.

* Opmerking

  • Als u de versnelling voor DirectDraw uitschakelt, schakelt u daarmee ook de versnelling voor Direct3D uit.

U kunt ook de vernieuwingsfrequentie van de monitor wijzigen die door de DirectDraw-toepassingen voor weergave op volledig scherm is ingesteld. U dient deze wijziging alleen aan te brengen als u daadwerkelijk problemen hebt met de weergave van een toepassing op het beeldscherm en u ervan overtuigd bent dat de toepassing een ongeldige vernieuwingsfrequentie instelt.

Een andere vernieuwingsfrequentie instellen

  1. Klik op de pagina Meer Help op Wijzigen.
  2. Selecteer in het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen de optie Andere waarde en voer een geldige vernieuwingsfrequentie in voor uw monitor.
  3. Klik op OK.

De gewijzigde vernieuwingsfrequentie annuleren en DirectDraw-toepassingen toestaan hun eigen vernieuwingsfrequentie in te stellen

  1. Klik op de pagina Meer Help op Wijzigen.
  2. Selecteer in het dialoogvenster DirectDraw-vernieuwingsgedrag wijzigen op Standaard.


Informatie opslaan

  1. Als u informatie die is verzameld met het diagnostisch hulpprogramma voor DirectX van Microsoft wilt opslaan, klikt u op Alle gegevens opslaan.
  2. De gegevens van alle pagina's worden opgeslagen in een bestand met de door u gekozen naam en locatie. Als u de gegevens wilt opslaan als een xml-bestand, klikt u in Opslaan als type op XML-bestand (*.xml).

* Opmerking

  • U kunt ook informatie opslaan door het volgende te typen achter de opdrachtprompt:

    dxdiag [/x uitvoerbestand] [/t uitvoerbestand]

    Bij deze opdracht worden door /x de gegevens opgeslagen als xml-bestand en door /t als tekstbestand. Met uitvoerbestand geeft u de naam en locatie van het betreffende bestand op.


Controleren op digitale handtekeningen van WHQL

Als u controleert of uw stuurprogramma's digitaal zijn ondertekend door de Windows Hardware Quality Labs (WHQL) van Microsoft, kan het zijn dat het diagnostisch hulpprogramma voor DirectX verbinding probeert te maken met het Internet om nieuwe WHQL-certificaten te downloaden. Tijdens dit proces wordt er geen informatie van uw systeem opgehaald. De eerste maal dat u het hulpprogramma uitvoert, wordt uw toestemming gevraagd om verbinding te maken met het Internet. Dit wordt slechts eenmaal gevraagd. Als u het antwoord wilt wijzigen, gaat u naar de systeempagina en schakelt u Controleren op digitale handtekeningen van WHQL in of uit.

U kunt dit ook wijzigen door het volgende te typen achter de opdrachtprompt:

dxdiag [/whql:on] [/whql:off]

Bij deze opdracht geeft u met /whql:on op dat het diagnostisch hulpprogramma voor DirectX moet controleren op WHQL-handtekeningen, en met /whql:off dat deze controle niet moet worden uitgevoerd.